Nets D2 for WooCommerce

  1. Home
  2. /
  3. Nets D2 for WooCommerce

Nets D2 for WooCommerce

Here you will find documentation on Nets D2 for WooCommerce.

The Nets D2 for WooCommerce plugin will soon be retired.
All new users should use the Nets Easy plugin.


Technical information


Plugin data


Plugin version: 2.7.0

Last updated: 15 May, 2020

Tested with

WordPress version: 5.4.1

WooCommerce version: 4.1.0

Requires at least

WordPress version: 4.3

WooCommerce version: 4.0.0

PHP version: 7.0

Plugin changelog


2.7.0
  • Tweak - Made recurring payments more compatible with new WooCommerce subscription flow.
  • Tweak - Declare support for WC 4.1.0 & WP 5.4.1.
  • Tweak - Change the name of the plugin to Nets D2 for WooCommerce.
2.6.2
  • Fix - Fixed error in MasterPass class related to WC_Session.
  • Fix - WC version deprecated notice fix. Could cause issues with cancel order redirect from DIBS payment window.
2.6.1
  • Tweak - Update DIBS ticket number in subscription during every subscription renewal payment.
  • Fix - Add maketicket (new DIBS subscription) even if it is a manuall subscription renewal. This can happen if customer pays for a renewal maually and selects DIBS as payment method.

View complete Changelog